プログラミング

VirtualboxGuestAdditionのバージョンがホストとゲストで一致していない

  • 2019.04.13

エラー内容 VirtualboxGuestAdditionのバージョンがホストとゲストで一致していないことで、エラーになっている。 ここまでうまく言ってるように思えない やはりバージョンが同じになっていない プラグイン入れたけど、更新されない。。。 バージョンが同じになったことを確認しました!! vagrantのバージョンをあげたことによって解決!!

ActiveRecord::PendingMigrationError

  • 2019.04.13

マイグレーションエラー エラーが出たとき 以下のコマンドを実行 あれ、またエラーでたw エラー内容 「bundle exec」をつけろってw 違いは以下のサイト参照 https://qiita.com/diskkid/items/0d000a42df04c561ca0f 参考サイト https://qiita.com/stammer_engineer/items/1585fa43ea490d235 […]

You must use Bundler 2 or greater with this lockfile

  • 2019.04.13

railsの環境構築しているときに出たエラー エラー内容 どうやらプロジェクトのbundleとGemfileのbandleがあっていないみたい Gemfile.lockの一番下に↓記載があった。 コマンドこのコマンドを打ってみた ずれている。。。。 バージョンがずれていることを確認!! あれ。。。 アップデートできない。。。。 問題はパーミンションかな? そういえば、確かrootでインストールした […]